mirror of
https://codeberg.org/Codeberg/pages-server.git
synced 2024-11-26 05:55:27 +00:00
044c684a47
closes #404 Reviewed-on: https://codeberg.org/Codeberg/pages-server/pulls/405 Co-authored-by: crapStone <me@crapstone.dev> Co-committed-by: crapStone <me@crapstone.dev>
28 lines
477 B
Nix
28 lines
477 B
Nix
{
|
|
outputs = {
|
|
self,
|
|
nixpkgs,
|
|
flake-utils,
|
|
systems,
|
|
}:
|
|
flake-utils.lib.eachSystem (import systems)
|
|
(system: let
|
|
pkgs = import nixpkgs {
|
|
inherit system;
|
|
};
|
|
in {
|
|
devShells.default = pkgs.mkShell {
|
|
buildInputs = with pkgs; [
|
|
glibc.static
|
|
go
|
|
gofumpt
|
|
golangci-lint
|
|
gopls
|
|
gotools
|
|
go-tools
|
|
sqlite-interactive
|
|
];
|
|
};
|
|
});
|
|
}
|